Loading Taint Vulnerabilities blocks Intellij for like 20 seconds

Hello,
we’re using the SonarLint Plugin for Intellij for a year now and we really like it. Our sonar cube ( Community Edition Version 7.9.5 (build 38598)) is located behind a VPN. If I’m connected to this VPN, then often, but not always, the status says “Loading Taint vulnerabilities …” and blocks the IDE completely for around 5 to 20 Seconds. I didn’t see any exceptions in the event log. Is there an option to turn off the Taint Vulnerability loading?

Best regards
Daniel

Hello,

Welcome to the community and thanks for raising this issue.

I created a ticket to fix it, you can track its progress if you want.

I don’t see any workaround in the meantime.

Thanks again
Damien

Hi Damien,

thank you for replying so fast. You’re doing a great job with the SonarLint Plugin!

Cheers,

Daniel

3 Likes

FYI this is the ticket to follow specifically for IntelliJ: https://jira.sonarsource.com/browse/SLI-514