JVM crash on Sonarqube 7.7 ES startup

sonarqube

(Carl Sjoquist) #1

Hi - I’m not sure what I should try now. would a different version of the JDK be worth trying? or different version of Sonarqube?

Thanks for your help! Great product nonetheless!
Carl

--> Wrapper Started as Daemon
Launching a JVM...
Wrapper (Version 3.2.3) http://wrapper.tanukisoftware.org
  Copyright 1999-2006 Tanuki Software, Inc.  All Rights Reserved.

2019.03.28 21:20:28 INFO  app[][o.s.a.AppFileSystem] Cleaning or creating temp directory /opt/sonarqube/temp
2019.03.28 21:20:28 INFO  app[][o.s.a.es.EsSettings] Elasticsearch listening on /127.0.0.1:9001
2019.03.28 21:20:28 INFO  app[][o.s.a.p.ProcessLauncherImpl] Launch process[[key='es', ipcIndex=1, logFilenamePrefix=es]] from [/opt/sonarqube/elasticsearch]: /opt/sonarqube/elasticsearch/bin/elasticsearch
2019.03.28 21:20:28 INFO  app[][o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running
2019.03.28 21:20:28 INFO  app[][o.e.p.PluginsService] no modules loaded
2019.03.28 21:20:28 INFO  app[][o.e.p.PluginsService] loaded plugin [org.elasticsearch.transport.Netty4Plugin]
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fa0c37d4b85, pid=55936, tid=0x00007fa10c3c5700
#
# JRE version: OpenJDK Runtime Environment (8.0_201-b09) (build 1.8.0_201-b09)
# Java VM: OpenJDK 64-Bit Server VM (25.201-b09 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [jna7712106003487132547.tmp+0x12b85]  ffi_prep_closure_loc+0x15
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /opt/sonarqube/logs/es_hs_err_pid55936.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
2019.03.28 21:20:32 WARN  app[][o.s.a.p.AbstractProcessMonitor] Process exited with exit value [es]: 134
2019.03.28 21:20:32 INFO  app[][o.s.a.SchedulerImpl] Process [es] is stopped
2019.03.28 21:20:32 INFO  app[][o.s.a.SchedulerImpl] SonarQube is stopped
<-- Wrapper Stopped

(Simon Brandhof) #2

Hi Carl,

Could you please provide a bit more details about your environment? OS, SonarQube configuration (sonar.properties), Docker runtime?

Thanks


(Carl Sjoquist) #3

Hi Simon

Sure - this is Sonarqube 7.7, on a vm. OS is Centos 7

Virtualization: vmware

Operating System: CentOS Linux 7 (Core)
CPE OS Name: cpe:/o:centos:centos:7
Kernel: Linux 3.10.0-957.10.1.el7.x86_64
Architecture: x86-64

I’ll attach our sonar.properties file, but not much changed there, just configured to point at a postgres db.

Thanks


(Carl Sjoquist) #4

The site is blocking me from including my sonar.properties file, something about new users not posting more that 6 links. But the only changes I’ve made are the jdbc settings to use a Postgres instance. I see a link that suggests we should make a change here:

https://www.elastic.co/guide/en/elasticsearch/reference/5.5/vm-max-map-count.html

So I’ll try that, but we are not seeing the warning it mentions:

When SonarQube runs standalone, a warning such as the following may appear in logs/es.log:

“max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]”

Thanks
Carl


(Carl Sjoquist) #5

no, that setting change didn’t make a difference for us, still crashes on startup on the Centos VM. I installed it to my Win10 laptop and it runs fine, just as a data point, but we really need it to run on the Centos VM.

Thanks
Carl