Issues SAML Azure AD SonarQube

Hey SonarSourcers, We are using SonarQube Version Enterprise Edition 8.5.1.38104 with a NGNIX Reverse Proxy SSL and trying to integrate with Azure AD SAML. We are getting the issue where all is working but the https://sonarserver/oauth2/callback/saml is issuing a redirect to Location:
http://sonarserver.trinet-devops.com/ instead of https. I am following the NGINX reverse proxy setup as described here for https: Operating the Server | SonarQube Docs. I also have the baseURL setting in sonarqube set to https://sonarserver. Not sure what is causing. The SAML portion is working, user is registered, session is created, navigating to https url works. any ideas?

I did a workaround by having the NGINX project issue a 301 client side redirect back to the https:// address. I still never got any information on why the initial redirect above was http instead of https.