SonarQube SSO Integration with Azure AD

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    – sonarqube-
  • how is SonarQube deployed: zip, Docker, Helm
    – zip
  • what are you trying to achieve
    – integrate Azure AD for Single Sign On
  • what have you tried so far to achieve this

We are working on integrating Azure AD with Sonarqube instance for Single Sign On. We have followed the documentation below and created the resources in Azure and enabled the SAML Authentication in Sonarqube but we are not able to login using SAML and seeing below error.

Documentation followed:

Error in Sonarqube :

2023.09.04 09:47:42 ERROR web[AYpgqX9q95zYrSHOAAAy][c.o.s.a.SamlResponse] The response was received at instead of
2023.09.04 09:47:42 ERROR web[AYpgqX9q95zYrSHOAAAy][c.o.saml2.Auth] processResponse error. invalid_response

We then have tried to update the SSL Profile Settings in F5 Load Balancer but that didn’t work too. We were not able to load the Sonarqube website when tried with this setting, so we rolled back.

Moved the highlighted SSL secure option to Selected field to apply the SSL Profile.

We currently have this Secure Connection field as empty, do we need to select the ssl option in order to make this work ?

We only have one Sonarqube instance, so we are not able to test this.

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!


Welcome to the community!

Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

9.0 → 9.9.1 → 10.2 (last step optional)

You may find these resources helpful:

If you have questions about upgrading, feel free to open a new thread for that here.

If your error persists after upgrade and use of the latest documentation (9.9, 10.2), please come back to us.


Hi Ann,

We did upgrade the cluster to version 9.9 and we are still seeing the same error.
FYI, we are using F5 loadbalancer to route the traffic to the instance.


Hi Abhinav,

Congratulations on your upgrade!

Are you using an IIS proxy? If so, this guide may help.


Thank you Ann :).

We have hosted the Sonarqube instance on a Linux box.
NO, we are not using IIS Proxy.


Hi Abhinav,

Then this is likely a misconfiguration of http vs https, somewhere.