IssueList remains empty while overview show bugs and smells

Must-share information:

  • which versions are you using
    • sonarqube-developer- (Linux) using the embedded database
    • sonar-scanner-
    • build-wrapper, version 6.9 (linux-x86)
  • what are you trying to achieve
    Analyze a C/C++ project (evaluation)
  • what have you tried so far to achieve this
    I’m trying to set up sonarcube for a C/C++ project. After some searching and a bit sweat I was able to have the project analyzed, good! It detected a few bugs and codesmells, which I can see in the overview (this seems to indicate that the analysis phase worked fine). But when I click to see more details, the list of issues remains empty. In fact the entire “issues” tab is empty and says “No Issues. Hooray!”

Problem to be resolved: how do I actually get to see the issues in the issuelist?

I found this backtrace in the ce.log file:

2020.06.08 13:35:33 ERROR ce[AXKTtr4Y2E3QqzLTPFYy][o.s.c.t.CeWorkerImpl] Failed to execute task AXKTtr4Y2E3QqzLTPFYy
java.lang.IllegalStateException: Unrecoverable indexation failures: 1277 errors among 1277 requests
	at org.sonar.server.component.index.ComponentIndexer.delete(
	at org.sonar.ce.task.projectanalysis.purge.IndexPurgeListener.onComponentsDisabling(
	at org.sonar.db.purge.PurgeCommands.purgeDisabledComponents(
	at org.sonar.db.purge.PurgeDao.purgeDisabledComponents(
	at org.sonar.db.purge.PurgeDao.purge(
	at org.sonar.ce.task.projectanalysis.purge.ProjectCleaner.purge(
	at org.sonar.ce.task.projectanalysis.purge.PurgeDatastoresStep.execute(
	at org.sonar.ce.task.step.ComputationStepExecutor.executeStep(
	at org.sonar.ce.task.step.ComputationStepExecutor.executeSteps(
	at org.sonar.ce.task.step.ComputationStepExecutor.execute(
	at org.sonar.ce.task.projectanalysis.taskprocessor.ReportTaskProcessor.process(
	at org.sonar.ce.taskprocessor.CeWorkerImpl$ExecuteTask.executeTask(
	at org.sonar.ce.taskprocessor.CeWorkerImpl$
	at org.sonar.ce.taskprocessor.CeWorkerImpl.findAndProcessTask(
	at org.sonar.ce.taskprocessor.CeWorkerImpl$TrackRunningState.get(
	at java.base/java.util.concurrent.Executors$
	at java.base/
	at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/


Even without the stacktrace (thanks for including it!) I knew that you were having ES problems, because the Issues page is populated from the Elasticsearch indices. Now the question is the extent of your ES problems. Were there any other stacktraces in your log?

Clearly you have a bad index. You can fix that by stopping the server and deleting $SONARQUBE-HOME/data/es6. When you start the server back up the indices will be rebuilt automatically. However, you should keep an eye on this log while that’s happening. It’s possible that the indices are bad because ES locked them because it didn’t have enough free disk space to make it happy. If that’s the case, you’ll need to free up some additional disk space before this will work.


1 Like

Hi Ann,

Thanks a lot for your fast answer.

You’re right, the es.log indicated that eleasticsearch was running out of diskspace, even with over 13GB free diskspace. Increasing the free diskspace from 3.2% to 6% made elasticsearch happier.

2020.06.08 14:57:24 WARN  es[][o.e.c.r.a.DiskThresholdMonitor] flood stage disk watermark [95%] exceeded on [Ftyy-hidQYG0GasauYrNrg][sonarqube][/home/rv/projects/2020/0608-sonarqube/sonarqube-] free: 13.1gb[3.2%], all indices on this node will be marked read-only

At that point, simply deleting the es6 folder combined with a restart fixed the issue.



1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.