IntelliJ SonarLint "Enable Proxy" disabled

To connect to sonarqube i need a proxy, specifically a proxy.pac. While the settings in intellij are working fine i am not able to use these settings in SonarLint setup - the check box is disabled.

So how to enable the proxy?

Thanks in advance

Hi @Max_Muller

I just made a manual testing session, and this checkbox is useless :sweat_smile:. SonarLint will reuse IntelliJ proxy settings, whatever is the state of this checkbox. I have tested both manual and automatic (using .pac) configuration and that was working fine.
I have created a ticket to fix this UI glitch, but in the meantime you should be able to use SonarLint with your proxy, ignoring this checkbox.

If you still have problems (maybe related to proxy authentication), then this is a different issue, and you’ll have to provide more details about your proxy.

Thanks for your investigation and time.
In my case i am using a pac file that sets a proxy only for specific addresses. It could be that this is not working in intellij - i will see.

I deleted the ticket since I finally found that the checkbox is used.

Any update on your side?