Installation non-response issue

Hi dear community,
I am new to the sonarqube and I have been trying to figure it our for some time. However, I am having an issue installing it. I have jdk and I downloaded the community edition.

When I tried to run the startsonar.bat, nothing happens and it does not execute anything. I also tried: C:\WINDOWS\system32>cd C:\sonarqube-\bin\windows-x86-64

Rather than installation I got: C:\sonarqube-\bin\windows-x86-64>
What’s the main problem and how can I install the sonarqube?


Welcome to the community!

How did you try to run the batch file? Did you double-click it? Or did you invoke it from a command line (hint: the latter is the way to do it for your first run).



I think I’m facing the same issue and it seems to be a bug on the StartSonar.bat.

I’ve just sent a pull request with a fix: Reset %errorlevel% after checks in batch scripts by felipebz · Pull Request #3304 · SonarSource/sonarqube · GitHub

1 Like

Thank you so much!

Hi @Bora_Kocak!

Thank you for reporting this issue. It seems to be connected to this bugfix.
It will soon appear on our repository.

In the meantime, as a workaround, you could manually update the 2 scripts as seen in the pull request.

Best regards,

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.