Incompatible Sonarqube server version error

IntelliJ IDEA version: 2019.2.3 (Ultimate Edition)
SonarLint plugin version: 4.2.0.3434
SonarQube version: Version 6.4 (build 25310)

When I try to add a SonarQube connection in the SonarLint General Settings either via using a Token or Credentials, I get the following error message:
“Failed to connect to server. Please check the configuration. Cause: SonarQube server has version 6.4.0.25319. Version should be greater or equal to 6.7”.

We are able to do this successfully on my colleagues machine who has an older version of IntelliJ. Is there a compatibility restriction which I am missing here?

Hello @pvijayvergia, thank you for your feedback.

Support for connected mode with SonarQube servers older than 6.7 (the previous LTS) was dropped with SonarLint for IntelliJ 4.2, as mentioned in the release notes.

I would strongly advise that you update your SonarQube server, 6.4 is more than 2 years old and there were 2 LTS releases inbetween (6.7, 7.9).

In the meantime and if upgrading your server is not a possibility for you right now, you can downgrade to SonarLint for IntelliJ 4.1.1.3345.

1 Like