How to solve the compute engine bottleneck problem?(only one worker)

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension): We are using sonarqube 7.2 community edition.
  • what are you trying to achieve: Because we can only configure one worker, there are too many background tasks lining up in the background. We are trying to increase the number of workers so that the background tasks won’t be clogging.
  • what have you tried so far to achieve this: I have searched the google and stackoverflow for relevant answers. But found nothing rather than commercial support. As for commercial support, I have not found how many workers that one instance can support, and what is its limitations.

Hi,

Welcome to the community!

First, 7.2 is past EOL. You should upgrade immediately. Your upgrade path is:

7.2 -> 7.9.4 -> 8.5.1 (last step optional)

Once you’ve upgraded, you still won’t have the ability to have multiple CE workers. For that you need to upgrade to Enterprise Edition($$). Once there, you’ll need to tune the number of workers you configure based on the resources available to SonarQube. If you opt for professional support, they’ll be happy to help you work out how many you can use.

 
HTH,
Ann

Hi, Ann.

Thanks for the reply. We’ll try to upgrade to a LTS version recently.

For the CE workers, I found that if the LoC reaches a certain level, such as 100k, then a worker will need to parse for like 8 mins. We use Quality Gate to judge if an analysis is passed, if passed, then approves the merge. 8 mins still seems a lot to us in the CI. So does sonarqube have a benchmark on how your worker performs under different LoC?
I would like to use these data to:
Firstly, urges development team to use microservices rather than a large chunk of code.
Secondly, see if it fits our needs; thus if Enterprise Edition is needed, help higher level management make decisions.

Thanks and regards

Hi,

Sorry, no. What I can advise is that you put more horsepower under SonarQube and then adjust the server settings in $SONARQUBE-HOME/conf/sonar.properties to allow SonarQube - specifically the Compute Engine - to use it.

 
HTH,
Ann