How to connect sonarqube through sonar lint seetings in intellij2023.3.2?

Please provide

  • Operating system: windows 11
  • SonarLint plugin version:
  • Programming language you’re coding in: spring boot
  • Is connected mode used:
    • Connected to SonarCloud or SonarQube (and which version):

And a thorough description of the problem / question:

hello, in this new version of intellij i dont see the sign + to add sonarqube url and connect it,

Hi @Ray75, thank you for your report.

Could you try to increase the height of the window? Perhaps it is too small to make this section appears.

i increased the height of the window and there is nothing, i dont understand why and i couldnt find any solution or another way to do so

That is a strange behavior. Perhaps this is linked to a specific theme from your Windows? Did you notice any other issues in the IntelliJ settings?

You could try to open the SonarLint settings page where the section is missing and press alt+insert; it is the shortcut to add a connection.

Hi @Ray75, I was able to reproduce the issue on Mac OS using the New UI. I fixed the issue by increasing the height of the dialog, or by disabling the New UI.

I created this bug ticket on our side, to avoid such issues in the future.