Getting error when binding sonarqube project via sonar lint in visual studio 2017


I was able to connect to sonarqube server by passing SonarQube server and project token . But when I tried to bind sonar qube project I am getting below error. like
Unexpected error during workflow execution: Failed to write credentials.

Below is the detail error.

You can change the exclusion options via the SonarLint project-level context menu i.e. Solution Explorer -> Select project(s)

Binding solution to SonarQube project: Download quality profile(s):

Successfully downloaded quality profile. Name: ‘Sonar way’, Key: ‘AWZ8lJQFYccq-RSQX07Q’, Language: ‘C#’

INFO: SonarLint connected mode no longer installs the analyzers NuGet packages. The analyzers embedded in the VSIX are used instead.

Binding solution to SonarQube project: Generating project rule sets

Unexpected error during workflow execution: Failed to write credentials.

Checking for suppressions…

Number of suppressions found: 0

Connecting to SonarQube server:

Connecting to SonarQube server: Validating credentials

HI Shirish,

Have you got any solution for this issue, as I am also facing same error while try connecting SonarLint to SonarQube server (

Same error, VS2019 16.4.6.

I get one additional line before the “Failed to write credentials” error.
“Ruleset binding: all projects need to be updated reference the generated ruleset.”

Every time the binding tries to run, an additional ruleset file is added to every project.

I have just deleted the .sonarlint and .sonarqube folders, etc as recommended!topic/sonarlint/_hgsvV6WHEU because I needed to switch from a localhost sonarqube to our corporate one.