Failing analysis ID: AYahv1qEgOyFzq3Rc5p8

The following analysis is failing for me: AYahv1qEgOyFzq3Rc5p8

Besides these, it seems like no PR analysis run at all? E.g.: GitHub actions update by basrieter · Pull Request #1683 · retrospect-addon/ · GitHub

It looks like no analysis has been run on this repo since May 2022:

And, it looks like your repo has both a file (used for Automatic Analysis) and a file (which should only be used for CI-based analysis).

I would suggest removing the file from your repo (and any branches that you’re currently trying to scan), if you want to keep using Automatic Analysis.

Thanks for the fast reply. I will change that. I know I kept the file to set the sonar.projectVersion= property so it would show up correctly in the GUI of SonarCloud.

I just checked the code and sonar.projectVersion should be supported through, but isn’t documented as such. I’ll ping our docs team!

1 Like

That is good to hear!

I just merged the changes but still get errors: ID=AYah5PK9-qmZzTSKajtl

Perhaps it would make more sense to enable CI analysis using GitHub Actions?

There’s a weird error on the backend. I’m going to flag this for attention – but you can try to switch to CI-based analysis if you want to get it up-and-running right away.

Thanks. I switched to CI for now to get things working (hopefully). Thanks for the fast support.

The CI is working now, but not on external PR’s. As they don’t have the secrets stored in the repository the PR orignated from. What is the preferred way of solving this?

EDIT: I think that was the reason I started using the Automatic Analysis.

@Colin Did the backend-team find any issue? I had to move back to automatic analysis, but it still won’t work. See Failing analysis ID: AYaoNxdf4aDtPUkTUP2l - #2 by BasRieter

Hello Bas,

I see you created a new post here:

If I understood correctly, it’s about the same repository as in this post? If so, please avoid creating multiple posts about the same issue, duplicates make it more difficult to resolve the original issue. So in order to have everything in one place, could you please close the new post and copy the content here?

And so could you please summarise what is your latest issue? The problem is with Automatic Analysis or with CI-based analysis not working as expected?


Hi Peter, sorry about the duplicate post (about the same repo).

The initial issue was with the automatic scans. They apparently just stopped a while ago for my repo.

So I switched over to the CI build but that does not work for external PR’s. So I moved back to the automatic scanning, as the PR’s did work with that. But the Automatic build still fails.

So my issue is with the automatic scans that fail for my repo: GitHub - retrospect-addon/ Retrospect is a Kodi video add-on which allows you to watch streams of a number of free and publicly available online TV stream sites.

It also does not detect new PR’s in the repo.


Ok thank you for the clarification.

I tried to reproduce your issue. I created a fork of your repository on GitHub and imported it on SonarCloud - the Automatic Analysis was successfully executed and results visible in the UI. I created a PR and it was also detected and analysis was executed.

Would it be possible for you to re-create your project on SonarCloud? It means deleting the project on SonarCloud and re-importing it from GitHub. However, because of this action you would lose the history of your analyses etc.

It would be unfortunate to loose all that information. Is there no way to find out what the actual error is beloning to the error ID?

Any update on this @Peter_Horvath? I went ahead and re-imported the project (and lost all history). But still have issues with PR’s not being done: AYb2yZEbnqQwurb8Y5nn

And now again the master branch if failing after a push: AYb7ODL8GANz5WVmDnn.

It seems like the other project in the origanisation is also not working: and that one will be removed due inactivity (housekeeping) in 22 days. That would not be OK.

Hello Bas

I am sorry for the lack of information on this.

I am actively analysing your issue and trying to find the root cause, need a bit more time.

Thanks for the additional info. Yes, a new housekeeping policy was implemented for organizations on the free plan and took effect in January.

Thanks for the update. Hopefully we can resolve the issue within 22 days, to prevent the housekeeping from cleaning up.


Just to give you a quick update. I had a look on the failed PR analysis first - the PR created in the forked repository. The problem of the failure is that during the process when we try to clone the remote branch feature-1673, it’s not found. It’s possible that we have a bug there. I’ll continue the investigation.

Thanks for the update. What about PR No more python2 by basrieter · Pull Request #1694 · retrospect-addon/ · GitHub. That one is not from a fork? It fails with code: AYcLcLHZg48Yoyt3YPsd

Hi @Peter_Horvath, any update? As this problem is affecting both repositories in (Retrospect and Sake), the latter will be removed due to inactivity soon. Is there any way to prevent that for now? As the analysis won’t trigger.