Failed connectivity to Gitlab


  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    Developer EditionVersion 9.3 (build 51899)
  • what are you trying to achieve
    Decorate my Gitlab MR
  • what have you tried so far to achieve this

I am trying to decorate my Gitlab MRs, and have followed this guide: GitLab Integration | SonarQube Docs

Everything seems fine, SonarQube analysis works and is reported correctly on SonarQube. However, the decoration part fails, with the following message:
“Merge Request decoration failed. Please check your configuration and the connectivity to GitLab”

When I go and check my Gitlab configuration, it shows that the configuration is valid:

Any ideas how to debug this?

Best regards,

Hey there.

  • Does importing projects from your GitLab repository work, or do you run into an error?
  • Have you double-checked the project-level settings to make sure the correct repository is being referenced?

Beyond that, you would want to bump up your log level (Global Administration > System > Log Level) and check which request is failing in your logs/ce.log file.

Bumping the log level led me to figure out that I was using CI_MERGE_REQUEST_ID instead of CI_MERGE_REQUEST_IID for sonar.pullrequest.key. It works now, thanks a lot.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.