Error while Installing SonarQube Community Edition

Hello Everyone, I have being trying to install sonarqube community edition but am getting an error message the Port 9001 is already being used binding failed
I tried overriding the settings in the Properties file but still the same error message
I cant kill the process using the Port number 9001 because it is used by “System” process
sonar queb is supposed to automatically pick port 9000 but mine seem to pick 9001 and its already used how do i get my sonar qube to start up

Hello @Donatello and welcome to the community :wave:

port 9001 is used for the internal communication with elasticsearch. if the port is already blocked on your system and you can not free it, you can change the port with the property in conf/

hope that helps :slight_smile:

EDIT to correct DCE parameter to CE parameter name

I have tried changing changing the port but it seems am not getting the write script format. am currently on version 8.7.0 maybe the override format is new

can you explain very detailed what you tried so far? i do not understand what you mean with

the first line is what is in the file originally
the second line is what I changed it to

still connecting to

the # here indicates that this line is commented out. the correct statement should be:

wow it’s working fine now thanks so much Tobias

no problem and have fun analyzing your projects with sonarqube :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.