Custom formats not loaded at start up

  • Operating system: Ubuntu Mate 22.04
  • SonarLint plugin version:
  • Programming language you’re coding in: PHP
  • Is connected mode used: No

I use custom formats for some rules. For instance, at rule php:S101, I set the format to ^[a-z][_a-zA-Z0-9]*$ instead of ^[A-Z][a-zA-Z0-9]*$

Every time I open PhpStorm, it says my class name does not follow the rule ^[A-Z][a-zA-Z0-9]*$ (and that goes to all my custom formats). If I disable/enable any rule, all warnings go away

Hi @Rodrigo_Capile ,

Thank you. I created this ticket for the bug

The issue appeared to be a bit more concerning than expected. Any modifications to the rules in standalone mode are not considered after a restart, it requires to re-apply the settings. We will provide a fix for the next release; sorry for the inconvenience.

1 Like

We just released SonarLint 10.4.2, which includes a fix to this issue. Could you please try updating it and see if it got resolved?

It is fixed. Thank you!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.