Coverage on .tsx files are got getting analysed by sonarqube community version

Hi team, we are using sonarqube community version 8.9.10 and installed using docker.
It is successfully analyzing .ts files in another projects but it is not able to analyze .tsx files.

we are using sonarscanner from bitbucket pipelines.

  • pipe: sonarsource/sonarqube-scan:1.1.0
    EXTRA_ARGS: ‘-Dsonar.projectKey=project1 -Dsonar.sources=src -Dsonar.typescript.tsconfigPath=tsconfig.json -Dsonar.typescript.file.suffixes=.tsx,.ts -Dsonar.language=ts’
    - pipe: sonarsource/sonarqube-quality-gate:1.1.0

I have tried multiple option inducing -Dsonar.inclusions with .tsx files but it was not working.Additionally, i have tried running this without any src folder details even then it was not analysing .tsx files.

please help us in this regard.


Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

8.9.10 → 9.9 → 10.0 (last step optional)

You may find these resources helpful:

If you have questions about upgrading, feel free to open a new thread for that here.

If your error persists after upgrade, please come back to us.

1 Like