Clover Coverage Analysis sensor not firing on Groovy projects

  • SonarQube v8.5 (build 37579)
  • SonarQube Plugins: Groovy v1.6, Clover v4.1 (others can be seen in the screenshots below). (I have experimented with Groovy v1.7-SNAPSHOT, but it didn’t make a difference and caused problems so I had to roll it back).
  • SonarQube Gradle Plugin v2.6.1 (I have tried newer versions of this plugin, but it didn’t make any difference)

I have been unable to figure out why I cannot get the Clover coverage reports imported for Groovy projects on a SonarQube EE (8.5) instance. Coverage for these projects are imported properly on our SonarQube CE (6.7.7) instance.

I am setting the sonar.clover.reportPath property (see screenshot) and the file is present/valid on the build server. However, I am getting the following message when I run my (Gradle) SonarQube scan with debug-level logging:
‘Clover Coverage Analysis’ skipped because there is no related file in current project. I’ve tracked the message down to this line of code, but I don’t know enough about how the scanner executes to be sure why the sensor is being disqualified.

What am I missing?

Any assistance is appreciated.

1 Like

Hi,

Welcome to the community!

Sorry, but the Clover plugin isn’t supported here. Normally I would direct you to filing an issue on that project, but I’m not certain it’s actively maintained anymore.

 
:woman_shrugging:
Ann

Yeah, I realize that Clover isn’t supported, I’ve been through this with support.

I have filed an issue on their tracker. However, I’m not convinced that this is an issue with the Clover plugin since I am able to import coverage on Java projects. It seems more likely that this is an issue with either the Groovy plugin (also likely not supported) and/or the enterprise scanner itself.

So…let me ask this a different way. Generically-speaking, how can I figure out the criteria that is disqualifying a sensor (the line of code that I pointed to above)? Are there debug/trace-level logs that can give me more insight behind that message?

Each plugin decides which language(s) it runs on.

Looks like the plugin defines the wrong language key, groovy rather than grvy

3 Likes

Colin…thank you so much!

I had noticed that while I was looking through all of the plugin code, but thought that might be a little too easy.

1 Like

In case anybody else runs into this…

A PR has been submitted to sonar-clover: https://github.com/sfeir-open-source/sonar-clover/pull/45

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.