Bitbucket pull request integration not working for all team members

When I look at a PR the sonar widget seems to work fine like so:

But some (maybe all) of my teammates are just getting a blank space like this:

Following this guide it seems like everything should be setup properly

Not sure if it’s relevant but the side menu widget seems to work fine

Not sure how to debug from here


I’ve also been experiencing this issue. When I monitor the console (via Dev Tools), I noticed the following error being reported:

Failed to load resource: the server responded with a status of 401 ()

The URL that generates this error:

The same occurs whether I’m viewing a recent (still open) merge request, or an older (already merged) one.

I’ve also tried removing the SonarCloud app from BitBucket & configuring it again from scratch - but this did not resolve the issue.

I have since found the following posts, but none of these yielded anything that has resolved the issue for me:

for me and my team it all worked fine till a week ago. See Bitbucket pull request widget is no longer working

Hello and thanks for the report.

We are currently investigating a very similar issue on this thread, so don’t hesitate to follow the progress there:

The fix has been deployed, the widget should load correctly again on your PRs!
We would like to apologize again for the long waiting time, thank you for your patience with this issue.

@Gregoire_Aubert I’ve confirmed that this has fixed the issue for our PRs.

Much appreciated!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.