Bitbucket: Pull request decoration did not happen

Must-share information (formatted with Markdown):

  • which versions are you using? * Version 8.3.1
  • what are you trying to achieve? Pull Request decoration in Bitbucket
  • what have you tried so far to achieve this? It already worked and stopped working some days ago. I don’t know how to get it fixed and need some help…


You’ll need to provide details of what you’ve tried and what the results were.



After i got this error described above i tried to create a new API Token with admin rights but i still get the same error.


What error?


There is no error log, but the issue is that the Pull Requests doesn’t get decorated. Can you help me what i could try?


Hi @danieldaeschle,

Could you turn your ce.logs in DEBUG and share the logs here please ?

A part from that, has there been a change in your network configuration, maybe there is an issue connecting to the BitBucket Server URL ?



Could you check these 2 things, please:

  • The pull request key is correct and matches the pull request ID in the BB server
  • The repository slug is correctly configured in the pull request decoration settings under the project’s administration.

I restarted sonarqube and now it works… :no_mouth:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.