AzureDevOPs Integration not reporting quality gate status to AZDO

After upgrade of SonarQUbe to 10.2, i can see like many PR builds are failing because of Quality Gates not reporting back to AZDO. .
If i check some of the projects i can see that the configuration is gone:

I need to enable manually each project.

Another problem i have is that Developers needs to be Administrator of the platform in order to enable back the integration.

is there an automated way to enable the integration of each project or grant permissions to Devs without being Administrators?

1 Like

Hey there.

The issue is probably less that the configuration is gone, but that it was never there in the first place.

From the Upgrade Notes

Deprecated pull request configuration properties removed
DevOps Platform Integration settings are no longer inferred from scanner-level analysis parameters, which were deprecated in SonarQube 8.1. To prevent pull request decoration from failing, make sure you have configured each project with the settings found under the project-level Project Settings > DevOps Platform Integration.

This particularly affects users integrating with Azure DevOps who formerly relied on the Extension for Azure DevOps to pass these properties. (SONAR-17711).

Project administrators can enable this for themselves, as long as the instance-level configuration exists (set by a platform administrator). Read more about project-level permissions here.

Future projects, if provisioned by the onboarding wizard (in the SonarQube UI) will have these details automatically filled out. We will probably expand this to projects provisioned from first analysis (like we have for GitHub).