Azure Devops build with SonarCloud error

The following error gets during build with SonarCloud:
##[error]Nov 15, 2019 12:33:09 PM okhttp3.internal.platform.Platform log
Nov 15, 2019 12:33:09 PM okhttp3.internal.platform.Platform log
WARNING: WARNING: A connection to https://sonarcloud.io/ was leaked. Did you forget to close a response body? To see where this was allocated, set the OkHttpClient logger level to FINE: Logger.getLogger(OkHttpClient.class.getName()).setLevel(Level.FINE);

Actually the build was success.
Anybody has the same error?
Where can I set this logging level in Azure DevOps?

Hi,

Can you please send me the corresponding log ? So i’ll get a bit more context.

Thank you !

Mickaël

How can I send you logs? Here only pictures enabled…

Hi,

I created this ticket to troubleshoot the isssue : https://jira.sonarsource.com/browse/SCCOMM-13

We’ll investigate it as soon as possible.

Thanks.

Mickaël

Hello @mickaelcaro. Do you have any updates on this issue?
The ticket says that the issue has been resolved, but we are currently also experiencing these errors in our pipeline logs.

##[error]Feb 19, 2020 9:58:50 AM okhttp3.internal.platform.Platform log

Feb 19, 2020 9:58:50 AM okhttp3.internal.platform.Platform log

WARNING: WARNING: A connection to https://sonarcloud.io/ was leaked. Did you forget to close a response body? To see where this was allocated, set the OkHttpClient logger level to FINE: Logger.getLogger(OkHttpClient.class.getName()).setLevel(Level.FINE);

Hi @mickaelcaro!
I still have the same error during code analysis but you closed the issue with “Fixed” status.
Can you tell us how to fix this issue?

Hi @Peter_Karpati,

The issue was fixed on SonarCloud’s side, but still we need to update the extension with the latest internal component to take benefit of it, which should happen soon.

Mickaël