Authentication error when executing blame for file *****/pom.xml: svn: E170001: Authentication requ

I am using SonarQube:9.1 version,
Build getting failed in sonar stage with below error, we would like to go ahead with scanner as : Dsonar.scm.disabled=false:
[ERROR] Failed to execute goal org.sonarsource.scanner.maven:sonar-maven-plugin:3.7.0.1746:sonar (default-cli) on project ***********: Authentication error when executing blame for file **************/pom.xml: svn: E170001: Authentication required for ‘****************> CollabNet Subversion Repository’ → [Help 1]
Can anyone please help me to resolve this.

Hey there.

You can configure SVN authentication by passing analysis parameters to the scanner, or, you can turn SCM integration off entirely by passing -Dsonar.scm.disabled=true to the scanner.

Hey,

Thanks for your reply

In our case we need to use -Dsonar.scm.disabled=false , and we are using -Dsonar.svn.username and -Dsonar.svn.password.secured in our sonar commands also.

When i checked above document two more parameter is mentioned sonar.svn.privateKeyPath and
sonar.svn.passphrase.secured do we need to add this (sorry, i am not aware about the useage of this)?

Can you please help me to identify anything else we need to add, for resolving the same.Below command we using while running sonar:
mvn -s /usr/share/.m2/settings.xml sonar:sonar -Dsonar.login= -Dsonar.host.url=********* -DanalysisMode=publish -Dsonar.projectName=‘’’ + projectName + ‘’’ -Dsonar.scm.provider=svn -Dsonar.svn.username=‘’’ + Owner + ‘’’ -Dsonar.svn.password.secured= -Dsonar.scm.disabled=false -Dsonar.projectKey=‘’’ + projectKey

Thanking your help in advance

These are only relevant if you can’t use password-based authentication for your SVN server.

Are you still facing an error after implementing this?

yes facing issue