Allow eslint-disable-line and nosonar to appear on same line

Using sonarlint for typescript in VS Code, I can’t do this, but I would like it to work:

location.href = location.href;  // eslint-disable-line // nosonar 

nosonar and eslint both insist they must be the first comment