After moving a repository from one Azure DevOps Project to Another [Same Org] the PR analysis fails


ALM Used: Azure DevOps
CI System: Azure DevOps

I’ve moved a repository from one AzureDevOps project to a different project in the same organization. I have the impression that the project stores some of the following settings in it’s database during the initial creation of the project and I haven’t found any place on where to update them - I’ve tried to put them into the advanced options of the “Preparation Step” - but they are ignored.

  • sonar.pullrequest.vsts.project=

How can I update the “vsts project” in SonarCloud that a project is associated with? I don’t want to loose all my history just because of moving the respository in DevOps to a different project.

Here’s the error message that is given during the analysis

Caused by: Error 404 on : {"errors":[{"msg":"Requested resource wasn\u0027t found on Azure DevOps.","reason":"AZURE_DEVOPS_UNABLE_TO_FETCH_REQUESTED_RESOURCE"}]}



I have figured out by now that a project is bound to a repository. This can be queried by

[type or paste code here](

but there is nothing in the UI nor could I guess any endpoint in the “/api/alm_integration” that would allow me to switch the “linkedProjects” from one repository to the other one.

I think that’s quite annoying and a quite big limitation. It would also be super nice if there would be ANY form of documentation on the /api/alm_integration.



Thanks for the follow-up. I’m glad you worked through this. I’ve flagged your post for team attention to see if there’s anything we want to do w/r/t the docs or the UX.