After adding repository I no longer have access to it

Template for a good bug report, formatted with Markdown:

  • Versions used: SonarCloud
  • Error observed: You are not authorized to access this page. Please log in with more privileges and try again.
  • Steps to reproduce:
    • Log in to sonarcloud
    • attempt to view repository by going to the add screen (it is added so you cannot add it again)
    • get Not Authorized error
  • Potential workaround: NA
  • Scanner command used when applicable (private details masked): NA
  • In case of SonarCloud: NA

Welcome to the community!

How did you add the repository?

Are you able to reproduce the problem by adding another repository the same way?

Thanks for the warm welcome, Janos!

We added the repository by selecting it from the list of available repositories from our bitbucket installation.

We have not been able to reproduce the issue with adding on any others so far. I’d like to just delete it and try again, but it says I don’t have access (even though I am an admin). :smiley:

The list you’re referring to, is it on Bitbucked Cloud, in the SonarCloud settings, or is it on SonarCloud? (The latter is the recommended way to import projects.)

I will contact you in a private thread to get more details about the project to clean up.

It is on SonarCloud. I click the plus sign in the top right, then “Analysze new project”, which then takes me to From there I can select additional repositories to scan, however it shows the one with the issue as already existing, and when I click the link in “Imported: See Project” it gives me the error above.

Hello Will,

Are you still having trouble accessing this project ?

Could you check that your permissions are correct on SonarCloud side ? As I understand you are administrator of the organization, so that means you should be in the “Owner” group of your organization. Does this “Owner” group has “browse” permission on your project ?

The way the permissions currently work, having only “Administer” permission over the project is not enough to access everything, you should also have “Browse” permission to have full access.

We are aware that this is not ideal and we definitely need to improve our permission system to make it simpler…

I hope this helps!