Add the compatibility rules for upgrading PHP Code

php

(Jean Baptiste Nahan) #1

Hi,

I am a new user for sonar. Before sonar, I used the PHP compatibility checker for help to upgrade the PHP code.

The tool is here:

How-to add this rules into Sonar ? or import the PHP compatibility checker result into the Sonar dashboard ?

Thanks in advance for your help.


(Nicolas Bontoux) #2

Hi,

You could leverage Generic Issue Data ! (available in latest SonarQube versions).


(Daniel) #3

This would be very useful to have builtin to the existing PHP rules