YAML quality profile has zero rules

SonarQube version:

In short, our SonarQube is no longer scanning yaml files (.yml or .yaml).

We’re not completely sure when this started happening, but I noticed the yaml quality profile has zero rules, and I’m suspicious that’s the issue.

If I go to Quality Profiles and filter by YAML, I find this:
YAML Analyzer (outdated copy since March 31 2024 at 10:27 PM)

After researching that “outdated copy” a bit, I tried modifying that profile to inherit from Sonar Way. I also tried creating a new YAML Analyzer, and inheriting from Sonar Way. Both still have the issue that they have zero rules with them.

A bit further digging… I believe we originally imported a YAML Analyzer profile, but the person who did this is no longer here. I’ve also learned plugins for SonarQube no longer exist.

Any suggestions on this? Any help is much appreciated!


Welcome to the community!

Your version is past EOL. You should upgrade to either the latest version or the current LTA (long-term active version) at your earliest convenience. Your upgrade path is:

9.7.1 → 9.9.4 → 10.4 (last step optional)

You may find these resources helpful:

If you have questions about upgrading, feel free to open a new thread for that here.

If your error persists after upgrade, please come back to us.


We’re now upgraded, to 9.9.4. We could not upgrade to 10.4 at this time as the changes are pretty drastic, including all sorts of database changes we’ll have to figure out, so we’re saving that for another day.

Anyways, 9.9.4 is a currently supported version, and we’re still having the same issue. Nothing has changed. SonarQube still doesn’t seem to be finding or scanning YAML files.


This is as expected

What are your YAML file names?


Our yaml files are all sorts of names, but always end in either .yml or .yaml


I asked about your YAML file names because YAML files are analyzed by other languages’ analyzers. It’s normal that there are 0 YAML rules.

There used to be a YAML plugin, but it was withdrawn a couple of years ago IIRC.