Version support - RHEL 6.10


(Surmeet) #1

Hi
Can anyone let me know whether SonarQube v4.5.4 is supported by RHEL 6.10?

Thanks in advance for your help.


(G Ann Campbell) #2

Hi,

In general it’s less a question of operating system version than Java version. That said, 4.5.4 was released 3.5 years ago. If you’re not already running it on that old version of RHEL (and therefore support is Q.E.D.) why would you be looking to start using it. Instead, you should either be looking at 6.7.5, the current LTS, or 7.3 the most recent release.

 
Ann


(Surmeet) #3

Hi Ann,
Thank you for the response.
Actually, we work in collaboration with the client environment, so the client is using SONAR 4.5.4 and we have to use the same at our end so that their is no coverage issues. We are running 4.5.4 on RHEL 6.8 at the moment so that is why was a bit concerned. As the server admin team reported a migration activity taking place wherein RHEL 6.x would be upgraded to RHEL 6.10, so that is why I had raised my concern in the forum.

Would really be helpful you can check on this as well and let me know about a possible solution.

Also, we are using JDK 7 and 8 version currently installed on RHEL 6.8, would that also be a problem if we go onto 6.10?

Thank you for your quick response in advance.

Regards,
Surmeet