UTF-8 Encoding issue in Username with open id connect

We are using open-idconnect with apache-proxy for login in sonarqube.
If a user with “umlaut” like “ö” loggs in via oidc, the ö is shown in the users list as ö.
If i create a user locally in sonarqube. The format is correct “ö”.

If i make a tcpdump -X between apache-proxy and sonarqube i can see the ö is just “…” (two dots).
A strace on the apache-proxy (oidc-provider <–> apache) shows “\303\266” where the ö is.

We are using Version 8.9.10 (build 61524) Community Edition

Hey there.

If you’re using GitHub - vaulttec/sonar-auth-oidc: OpenID Connect (OIDC) Plugin for SonarQube, I would recommend opening an issue with the maintainer on the GitHub repo!

Hey, thanks for fast reply!

I made another tcpdump on localhost:9000 (apache <–> sonar)

I put the Hex from the TCP-Packet (with the “ö”) into an Hex > Ascii-Converter:

656f c3b6 6c72
eo ö lr

Now i convert “c3 b6” into UTF-8 its “ö”.

Alle theese hex-values are ASCII and only the “c3 b6” is UTF-8.
How can i tell sonar to encode this “c3 b6” in UTF8 ?

Hey there.

You seem to have… completely ignored my reply. :laughing:

If you’re authenticating with OpenID via the plugin mentioned, you should raise an issue on their GitHub repo. That’s the side that handles receiving the name/username

Sonarqube is the receiving part here (not the sender…). Anyway, will create an issue there.

Okay now i switched the charset in the proxy to latin1. Now the “ö” is correct encoded in sonarqube.

But it is possible to change the default system encoding to utf-8 instead of latin1 ?

We have many systems using the proxy-settings and have to create a seperate config only for sonar.