Upgrading postgres version 9.5.16 to 9.6.18 version getting CPU hits 100%

P.S.: use the #bug:fault sub-category if you’re hitting a specific crash/error , or the #bug:fp sub-category for rules-related behaviour


Welcome to the community!

There are some DB maintenance steps that we recommend after upgrading your SonarQube version. At a guess, they may be helpful here too.


HI @ganncamp ,
Thanks for looking into this issue.
I didn’t upgrade sonarqube version,i tried to upgrade the database(postgres) version from 9.5 to 9.6
after that i removed the complete es6 folded and tried to index again, indexing is complete .but still sonarqube is not loaded .in that UI showing the massage loading.and DB CPU hits 100% ,I’m using 64GB Ram and 4cpus.

Hi, the VACUUM FULL recommendation does hold for PostgreSQL version upgrade as well.

PS: related discussion Sonarqube analysis taking 1+hr after DB upgrade to postgres10

HI @pierreguillot ,
I started VACUUM FULL ANALYZE. it’s started 6hous ago, but still not completed.
may I know how much time it will take?


Hi, I can’t say, it’s PostgreSQL specific commands. But basically, it’s re-writing your all database, table by table, to benefits from sequential reads from your disk. So it very much depends on your disk speed, and database size.

Thank you @pierreguillot
VACUUM FULL is resolved my Sonarqube issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.