Unable to sync SonarLint rules from SonarCloud

Please provide

  • Operating system: Windows 10.0.19045 Build 19045
  • Visual Studio version: Version 17.8.3
  • SonarLint plugin version: 7.5.0.82292
  • Programming language you’re coding in: C#
  • Is connected mode used: Yes
    • Connected to SonarCloud (and which version): Unsure how to check this version.

And a thorough description of the problem / question:
VS 2022, installed SonarLint.
Set it up on an organization SonarCloud config.
Linked the project. Set up quality gate rules.
I enabled the connected mode and connected it to the project configured above.

I have disabled localization warnings in the quality gate. I am still getting warnings for localization intentionality in the VS IDE.
An example: C# static code analysis
In the quality gate for the C# profile linked to the project in question, this rule, “Literals should not be passed as localized parameters”, is listed under the inactive rules.

I have tried updating the binding.

How can I get the local sonar lint to follow the rules set in the quality gate?

1 Like

Hey there.

Can you share your VSCode logs?

This is for Visual Studio, not VS Code.
How can I get equivalent logs in VS?

Any update on this issue?