Unable to start Sonarqube after connecting to db

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) : Sonarqube 10.2.1

  • how is SonarQube deployed: zip, Docker, Helm : Zip

  • what are you trying to achieve : Start Sonarqube

  • what have you tried so far to achieve this: After entering the db connections in the sonar.properties, we tried starting the sonarqube using StartSonar through Powershell. But it is not starting successfully. We are able to start the sonarqube when we comment all lines in sonar.properties. The error message stated that there was node lock. We removed all the locks, closed all existing processes, killed all threads in db and manually stopped any sonarqube instances running and tried but it is still not starting. Sonarqube is installed on a remote server and we opened the db connections and whitelisted to connect from this server as well to make sure the db is connecting.

Below are the logs
es.2024-01-04.log (5.5 MB)
ce.2024-01-04.log (21.5 MB)

Hey there.

Try deleting your /data/es8 folder and restarting.

HI, we tried that option as well but still does not work.

Are you still getting the same log message? The more information you can provide, the better.