Unable to see portfolio settings for some portfolios

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) 8.9.6 LTS
  • what are you trying to achieve: need to see portfolio settings options for portfolios
  • Have checked the permissions for the AD groups I’m part of, it has the full admin access/, I am an admin for the platform but still do not see portfolio settings for half of the portfolios. please advise

Thank you

Hi,

You can have global admin rights without having admin rights on individual Projects / Applications / Portfolios. While you may not see the administration menu options on individual Portfolios, you can still admin them through the global menu: Administration → Configuration → Portfolios.

 
HTH,
Ann

Hi,

Under below option, I can only see half of the portfolios that I have access to, I do not see other portfolios.

Administration → Configuration → Portfolios.

Hi,

Would the other half (that you can’t see) happen to be sub-portfolios? If so, you’ll find them under their parent portfolios.

 
HTH,
Ann

Hi,
No. I see 43 portfolios under portfolios tab

when I check the portfolios through admin tab, the list has only 20 portfolios

Thanks

Hi,

Thanks for coming back to me.

For years, it has been our standard advice to tell folks locked out of administering a project to use their global admin abilities to re-grant themselves permissions. Without ever having tested it, I assumed it was the same for Portfolios. But we all know what happens when you assume.

How do I know I’ve made an ass of myself? Because I just finished the testing that confirms it.

What I’ve learned is that if you don’t have Browse on a project, you can still see it in the global Portfolios administration (although you can’t get to the right page to administer permissions on it). If you have Browse but not Administer, then it disappears from the global administration.

However, as a global admin, you can still use the APIs directly to give yourself the permissions you need.

You’ll use api/permissions/add_user or api/permissions/add_group to grant admin on the Portfolios where you don’t already have perms. And from there you should be good to go.

And yes, I’ve reported this internally.

 
Ann

Hi again,

As a followup, we’re planning to fix this in SONAR-16351

 
Ann

Hi again,

It’s just been pointed out to me that you do have access to re-grant yourself perms to a portfolio:

Administration → Projects → Management → [choose ‘Portfolios’ in the first dropdown]

There you get a list of all portfolios (even the ones you’re locked out of) and you have an option to Edit Permissions in the row’s cog menu.

 
HTH,
Ann