Unable to login with SSO

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • how is SonarQube deployed: zip, Docker, Helm
  • what are you trying to achieve
  • what have you tried so far to achieve this

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!

Unable to login to sonar qube with sso, trying to setup with keycloak. After login in below error was displaying.please help us witht the steps to fix the below issue
Sonar qube issue

Hey there.

Is the URL (that you’ve redacted) you’re redirected to the same URL that you access your SonarQube server?

Yes colin.Same URL is used for sonarqube.

I tried it in other way as well through gitlab, getting unautriozed error at sonar qube end after providing authorization in gitlab. Please check and confirm where the changes need to be done.

When I tried with keycloka received below error.

For the Gitlab case, you’ll want to look into the logs to understand the failure.

For SAML, you need to make sure the x-forwarded-proto is set to https.

Can you please provide the http reverse proxy with x-forwarded-proto option.

Unable to get it for http reverse proxy.