Cannot log-in via https proxy

Good day,

We are having an issue with logging into our instance of SonarQube (Developer edition) v9.2.4.50792, via our instance of GitLab when using https. Can we ask for some advice on this please?

Initially, our SonarQube instance was set-up using the default port (http://sonar:9000/, etc) and with that configuration, integrated it with our GitLab instance (https://gitlab/, etc). We are able to get our projects into SonarQube and perform code analysis using this just fine.

Later, we have decided to get our SonarQube instance behind an https proxy, and so we followed the instructions in Configure SSL for SonarQube on Windows to set it up. Logging into https SonarQube (https://sonar/) using accounts made in SonarQube works fine. All seemed well until we tried logging into https SonarQube with our GitLab accounts. When attempting to log in https SonarQube with GitLab, we get redirected back to https://sonar/ without getting into the GitLab login page.

To note, our GitLab instance has been configured such that SonarQube is registered as an application, with the redirect url set to https://sonar once we have set-up our https proxy, and all relevant scopes checked. Also, on our SonarQube instance, sonar.core.serverBaseURL has been set to the same url. Our servers are inside our private network, and all certificates are accounted for.

Hi,

Welcome to the community!

When you reconfigured, after adding the proxy, did you maybe mis-set the GitLab URL? I would start by double-checking all the GitLab auth configs inside SonarQube, going over each one as though you were setting this up for the first time.

 
HTH,
Ann

1 Like

Hi Ann,

The GitLab URL remains the same and hasn’t changed. I’ve also double checked the GitLab API URL and it also remains unchanged. Our instance is working fine, other than not being able to login from the https://sonar/ page.

As mentioned on a previous post (that I’ve since deleted) http://sonar:9000/sessions/init/gitlab?return_to%2F initiates a request to

https://gitlab/oauth/authorize?response_type=code&client_id=...&redirect_uri=https%3A%2F%2Fsonar%2Foauth2%2Fcallback%2Fgitlab&scope=api&state=...

On the other hand, https://sonar/sessions/init/gitlab?return_to%2F initiates a request to

https://sonar/oauth/authorize?response_type=code&client_id=...&redirect_uri=https%3A%2F%2Fsonar%2Foauth2%2Fcallback%2Fgitlab&scope=api&state=...

which is perhaps why the login doesn’t go through

I’m gonna go through our configurations again today just in case.

Thanks,

mbrian

1 Like