Unable to log in after upgrading to 9.1 version - Crowd LDAP issue


We upgraded SonarQube from version to 9.1 and now we have issue connecting to our server for some reason - We went from 8.7 to 8.9 LTS, ran some tests there and everything worked as expected. Then we upgraded to 9.1 and we have an issue with login - We are using crowd as our LDAP authentication server and nothing is changed in the config - Crowd Plugin that we use is sonar-crowd-plugin-2.1.3.jar.

The server seems to be working fine as we have no issues running scans using Jenkins jobs, its just that login to the server does not work…

Any assistance would be appreciated

Thank you !


What do your server logs say?


we have same issue after upgrading from Sonaqube 8 to 9.2.4, logs say nothing, browser logs just print 401, access log answer 401 too for auth requests.

trying to change user/password on jira user server for sonar - no effect

Hi @Sergey_Subbotin,

Welcome to the community!

In fact, this has come up internally, recently. From 8.9 there’s the requirement to accept the risk of using 3rd party plugins. But since you’re using a 3rd-party plugin to log in, there’s a conflict. As a patch, you can “pre”-accept the plugin risk consent in order to use an authentication mechanism that hinges on the plugin risk consent checkbox.

  • This requires setting sonar.plugins.risk.consent=ACCEPTED in the sonar.properties file.

To be honest, this is a hack. Setting this value in sonar.properties shouldn’t work, but for now it does. By the time we close that hole, I’m sure we will have worked through this other problem.