Unable to install SonarLint Eclipse 4.2

Hi,

I have Neon Eclipse IDE version 4.6.3 and JDK 1.8.212 and I am trying to install Sonar Lint. When i look for Sonar Lint in Eclipse Marketplace, the option available is SonarLint4.2 and on installation, I get the following errors:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.sonarlint.eclipse.cdt,4.2.0.201909192007
No repository found containing: osgi.bundle,org.sonarlint.eclipse.core,4.2.0.201909192007
No repository found containing: org.eclipse.update.feature,org.sonarlint.eclipse.feature,4.2.0.201909192007
No repository found containing: osgi.bundle,org.sonarlint.eclipse.jdt,4.2.0.201909192007
No repository found containing: osgi.bundle,org.sonarlint.eclipse.m2e,4.2.0.201909192007
No repository found containing: osgi.bundle,org.sonarlint.eclipse.ui,4.2.0.201909192007
No repository found containing: osgi.bundle,org.sonarsource.sonarlint.core.sonarlint-client-api,4.5.0.2626
No repository found containing: osgi.bundle,org.sonarsource.sonarlint.core.sonarlint-core,4.5.0.2626

Even I tried with older versions, but still found the same errors.
Could someone please help me in getting rid of this error and get the Sonar Lint installed in Eclipse?

Thanks in advance!

Regards,
Sumitra

Hi Sumitra,

I had the same issue right after doing the release. Seems Eclipse p2 is having some cache somewhere, because after a few retries/restart, it worked. I just tested again using Eclipse Neon, and I was able to install from the marketplace. One thing you can try is to go to Eclipse preferences and remove the SonarLint update site, and install again from the marketplace.

Hi Julien,

Thanks for your reply!
I tried removing the SonarLint update site but still the installation did not work and I found the same errors again.

Even I tried clearing Cache of Eclipse and tried restarting eclipse before installation, but no progress. Lastly, I tried creating new Workspace, but still the installation fails.

It would be really great if you give me a solution to it, as I could not install any of the SonarLint versions?

Regards,
Sumitra

Can you try to download manually the update site archive:
https://binaries.sonarsource.com/SonarLint-for-Eclipse/releases/org.sonarlint.eclipse.site-4.2.0.201909192007.zip

And then use it to install (Eclipse -> Help -> Install New Software -> Add -> Archive)

Thank you so much, Julien! SonarLint is installed now :slight_smile:

But at first I really did not believe that adding to Archive will work as i thought what’s the difference in doing this, but still gave a try and it worked.

Anyways, I am thankful to you and happy that it worked.

Same for me. I have to admit Eclipse p2 client is very mysterious to me (to stay polite) :slight_smile:

Anyway I’m glad you managed to install the latest SonarLint.