Unable to find artifacts when installing SonarLint to Eclipse

Please provide

  • Operating system: Mac OS
  • SonarLint plugin version:
  • Programming language you’re coding in: Java
  • Is connected mode used: N/A (but will be yes once installed)
    • Connected to SonarCloud or SonarQube (and which version):

And a thorough description of the problem / question: Unable to install SonarLint to Eclipse 2024-03. Error received:
An error occurred while installing the items

session context was:(profile=_Users_tw038608_eclipse_jee-2024-03_Eclipse.app_Contents_Eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null → [R]org.sonarlint.eclipse.cdt, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).

The artifact file for osgi.bundle,org.sonarlint.eclipse.cdt, was not found.

I tried installing from the Marketplace as well as dragging into Eclipse from SonarLint | Eclipse Plugins, Bundles and Products - Eclipse Marketplace | Eclipse Foundation but I get the same error.

Hi @walttaqo,

thank you for reaching out. Sadly, I cannot reproduce the issue, and the exception method is very sparse. I’ve tested installation from the Marketplace inside Eclipse, dragging into Eclipse and from the Update Sites we have directly.

Can you please try again and provide me with all the logs of Eclipse itself? What does the Error log view say when trying to install it?

If it still does not work, please try our Update Site directly as this looks like an issue with Eclipse and/or the marketplace and not with SonarLint.