Unable to disable mmapfs use in elasticsearch

Template for a good bug report, formatted with Markdown:

1 Like

Hello @Stefankrz,

node.store.allow_mmapfs has only been deprecated. It is still working in 6.8.

Add -Dnode.store.allow_mmapfs=false to sonar.search.javaAdditionalOpts and you won’t run ES with nmap.

Note that this is not an official feature and it can be changed in the future.

I created SONAR-12264 to remove usage of the deprecated Es setting.

1 Like

Thanks, That has got sonarqube up and running for us