SonarQube Failing to start

I have sonarqube running in an azure container instance. I’m trying embed a database however, I’m getting the following errors. I have the following environment variables set on the container instance

sonar_search_javaAdditionalOpts =|

2022.04.18 03:10:31 INFO  app[][o.s.a.AppFileSystem] Cleaning or creating temp directory /opt/sonarqube/temp
2022.04.18 03:10:31 INFO  app[][] Elasticsearch listening on [HTTP:, TCP:]
2022.04.18 03:10:31 INFO  app[][o.s.a.ProcessLauncherImpl] Launch process[[key='es', ipcIndex=1, logFilenamePrefix=es]] from [/opt/sonarqube/elasticsearch]: /opt/sonarqube/elasticsearch/bin/elasticsearch
2022.04.18 03:10:32 INFO  app[][o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running
warning: no-jdk distributions that do not bundle a JDK are deprecated and will be removed in a future release
2022.04.18 03:10:37 INFO  es[][o.e.n.Node] version[7.16.2], pid[4423], build[default/tar/2b937c44140b6559905130a8650c64dbd0879cfb/2021-12-18T19:42:46.604893745Z], OS[Linux/5.4.81-microsoft-standard/amd64], JVM[Eclipse Adoptium/OpenJDK 64-Bit Server VM/11.0.13/11.0.13+8]
2022.04.18 03:10:37 INFO  es[][o.e.n.Node] JVM home [/opt/java/openjdk]
2022.04.18 03:10:37 INFO  es[][o.e.n.Node] JVM arguments [-XX:+UseG1GC,, -XX:ErrorFile=../logs/es_hs_err_pid%p.log, -Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -Djna.tmpdir=/opt/sonarqube/temp, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dio.netty.allocator.numDirectArenas=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j2.formatMsgNoLookups=true, -Djava.locale.providers=COMPAT, -Des.enforce.bootstrap.checks=true, -Xmx512m, -Xms512m, -XX:MaxDirectMemorySize=256m, -XX:+HeapDumpOnOutOfMemoryError, -Des.path.home=/opt/sonarqube/elasticsearch, -Des.path.conf=/opt/sonarqube/temp/conf/es, -Des.distribution.flavor=default, -Des.distribution.type=tar, -Des.bundled_jdk=false]
2022.04.18 03:10:38 INFO  es[][o.e.p.PluginsService] loaded module [analysis-common]
2022.04.18 03:10:38 INFO  es[][o.e.p.PluginsService] loaded module [lang-painless]
2022.04.18 03:10:38 INFO  es[][o.e.p.PluginsService] loaded module [parent-join]
2022.04.18 03:10:38 INFO  es[][o.e.p.PluginsService] loaded module [reindex]
2022.04.18 03:10:38 INFO  es[][o.e.p.PluginsService] loaded module [transport-netty4]
2022.04.18 03:10:38 INFO  es[][o.e.p.PluginsService] no plugins loaded
2022.04.18 03:10:38 INFO  es[][o.e.e.NodeEnvironment] using [1] data paths, mounts [[/ (overlay)]], net usable_space [46.6gb], net total_space [49.2gb], types [overlay]
2022.04.18 03:10:38 INFO  es[][o.e.e.NodeEnvironment] heap size [512mb], compressed ordinary object pointers [true]
2022.04.18 03:10:38 INFO  es[][o.e.n.Node] node name [sonarqube], node ID [FWbWyzMsRQuJ0P5dusVVIQ], cluster name [sonarqube], roles [data_frozen, master, remote_cluster_client, data, data_content, data_hot, data_warm, data_cold, ingest]
2022.04.18 03:10:45 INFO  es[][o.e.t.NettyAllocator] creating NettyAllocator with the following configs: [name=unpooled, suggested_max_allocation_size=256kb, factors={es.unsafe.use_unpooled_allocator=null, g1gc_enabled=true, g1gc_region_size=1mb, heap_size=512mb}]
2022.04.18 03:10:46 INFO  es[][o.e.d.DiscoveryModule] using discovery type [zen] and seed hosts providers [settings]
2022.04.18 03:10:46 INFO  es[][o.e.g.DanglingIndicesState] gateway.auto_import_dangling_indices is disabled, dangling indices will not be automatically detected or imported and must be managed manually
2022.04.18 03:10:47 INFO  es[][o.e.n.Node] initialized
2022.04.18 03:10:47 INFO  es[][o.e.n.Node] starting ...
2022.04.18 03:10:47 INFO  es[][o.e.t.TransportService] publish_address {}, bound_addresses {}
2022.04.18 03:10:47 INFO  es[][o.e.b.BootstrapChecks] explicitly enforcing bootstrap checks

ERROR: [1] bootstrap checks failed. You must address the points described in the following [1] lines before starting Elasticsearch.
bootstrap check failure [1] of [1]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
ERROR: Elasticsearch did not exit normally - check the logs at /opt/sonarqube/logs/sonarqube.log
2022.04.18 03:10:47 INFO  es[][o.e.n.Node] stopping ...
2022.04.18 03:10:47 INFO  es[][o.e.n.Node] stopped
2022.04.18 03:10:47 INFO  es[][o.e.n.Node] closing ...
2022.04.18 03:10:47 INFO  es[][o.e.n.Node] closed
2022.04.18 03:10:48 WARN  app[][o.s.a.p.AbstractManagedProcess] Process exited with exit value [es]: 78
2022.04.18 03:10:48 INFO  app[][o.s.a.SchedulerImpl] Process[es] is stopped
2022.04.18 03:10:48 INFO  app[][o.s.a.SchedulerImpl] SonarQube is stopped


Maybe the docs will help.


Hi Ann,

I read thru that article; however, the solution doesn’t seem to address running SQ in ACI. I tried to set a few variables I found online but it failed. One variable I tried was “SONAR_SEARCH_JAVAOPTS”="-Des.enforce.bootstrap.checks=false" Just looking around this variable: sonar_search_javaAdditionalOpts = is suppose to eliminate that error. This seems like common issue with running SonarQube in an ACI.


To be clear, you’re using the standard Docker image on your ACI? Because you’re hitting a minimum resources requirement for Elasticsearch that IIRC has been worked around in the supported Docker image.


yes I pulled the latest lts from It is version 8.9.8

Hi Ann,

Just to let you know. I figured out the issue. I didn’t have --cpu and --memory parameter passed in on the az container create command. The max_map_count error went away but I still got an error about Web sever startup failed, which in turn caused a Fail to connect to database error.

I know you can’t address that here so I don’t figure out what is causing the issue I will create another post.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.