Typo in documentation caused me a lot of grief

Not sure if this is the right place for this, if not please move it to the right place. The documentation here SonarScanner | SonarQube Docs has a missing space in the command for testing and analyzing a project. it has sonar-scanner -Dsonar.login=myAuthenticationToken when it should have sonar-scanner -D sonar.login=myAuthenticationToken. This caused me all sorts of trouble. If someone could fix this so no one has the same problem as me that would be awesome!

Welcome :slight_smile:

don’t know what was the real problem, but -Dkey=value is the correct syntax, means
there is no space between -D and the keyname.


1 Like

All I can tell you is that when i ran the command with no space on a windows machine, I got the following error “ERROR: Unrecognized option: .login=token” and when I ran it with a space it worked. Maybe this is a windows vs. linux problem but I can tell you definitively, that with the zip file I downloaded from the documentation, I had to use the command with a space between d and the keyname to make it work correctly.

that may be the solution for your problem