The 'report' parameter is missing with sonar gradle plugin 2.7 / 2.8

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • what are you trying to achieve
  • what have you tried so far to achieve this

I tried using sonar plugin 2.7/2.8 with gradle build within Jenkins pipeline. While running the sonarqube task, it failed with below error…

16:31:11.865 [DEBUG] [org.sonarqube.gradle.SonarQubeTask] Upload report
16:31:11.886 [DEBUG] [org.sonarqube.gradle.SonarQubeTask] POST 400 http://daycosnttu002.enterprisenet.org:21090/api/ce/submit?projectKey=&projectName=


16:31:11.926 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter] FAILURE: Build failed with an exception.
16:31:11.926 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter]
16:31:11.926 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter] * What went wrong:
16:31:11.926 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter] Execution failed for task ‘:sonarqube’.
16:31:11.926 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter] > The ‘report’ parameter is missing

Any help on this, please?

Hi,
Could you post the full logs of the scanner? Preferably with --debug.
Looks like there is no project key and project name passed in the post request which is odd.