The Jenkins Plugin for SonarQube does not set sonar.token for SonarCloud

Dear all,
I am trying to analyze a project in SonarCloud using Jenkins 2.429 and the SonarQube Extension Plugin for Jenkins 2.16.1
Since I do not pass the login/token property explicitly in the scanner, I found that the property is set correctly in SonarQube but not SonarCloud.
When I analyzed the project using SonarQube 10.2, the plugin uses the property sonar.token, however, when I changed the installation to SonarCloud, the plugin still sets the property to sonar.login.
I tried to set the property sonar.token explicitly in the analysis properties (just for testing purposes) and the warning still appears because the plugin already sets sonar.login.

Since the deprecation of this property is planned to be on 15th of this month I wonder what my options are, since the only option I see is to stop using the Jenkins extension and write the sonar-scanner command manually.

Thank you :slight_smile:

1 Like

Hi @mvillanueva

Thanks a lot for raising this issue!
I created an internal ticket to keep track of this defect and schedule it for a fix before the actual removal of this option.

Have a nice day,


Dear all,
I have updated the Jenkins plugin to the 2.17.1 and sonar.token is being used correctly. Thank you for the solution.
Best regards.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.