Supress ignore warning ==> WARN: Too many duplication references on file

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) : 8.3
  • what are you trying to achieve : scanning
  • what have you tried so far to achieve this: NA

Hello Team,
I am scanning a big repo (around 800 MB). It is scanning well. however I am getting below warning in huge number

WARN: Too many duplication references on file build/gen-code/generated-endpoints-idl/ for block at line 958. Keep only the first 100 references.

I want to ignore/avoid this warning so that it should not come on console.
Also, scan report size is also very big (250+ MB ). sometime it causes JAVA heap memory issue. There are 3 main process in sonarqube (web,elastic,ce). for which process should i increase java heap memory ?


You’re not going to be able to suppress those analysis-side warnings. They’re there to … warn you that some duplications may be overlooked.

For the analysis report size, where are you seeing the warning? If it’s on the analysis server, then you’ll need to adjust the analysis memory allocations. If it’s on the server side, then it’s the ce settings you want to tweak.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.