Start getting error [vm.max_map_count] on sonarqube

We are using 10.2.1 developer edition via helm chart config.
this is the config :
initSysctl:
enabled: true
vmMaxMapCount: 524288
fsFileMax: 131072
nofile: 131072
nproc: 8192
securityContext:
# Compatible with podSecurity standard privileged
privileged: true

resources: {}

These are logs getting in sonarqube pod :
[

  • [1] bootstrap checks failed. You must address the points described in the following [1] lines before starting Elasticsearch. For more information see [Bootstrap Checks | Elasticsearch Guide [8.11] | Elastic]

  • bootstrap check failure [1] of [1]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]; for more information see [Maximum map count check | Elasticsearch Guide [8.11] | Elastic]

  • ERROR: Elasticsearch did not exit normally - check the logs at /opt/sonarqube/logs/sonarqube.log

  • 2023.12.12 03:01:41 WARN es[o.e.n.Node] unexpected exception while waiting for http server to close

  • java.util.concurrent.ExecutionException: java.lang.IllegalStateException: Can’t move to stopped state when not started

  • at java.util.concurrent.FutureTask.report(Unknown Source) ~[?:?]

  • at java.util.concurrent.FutureTask.get(Unknown Source) ~[?:?]
    ]

on init-sysctl pod:
We are getting:
sysctl: permission denied on key “vm.max_map_count”, ignoring

any update?

@Matteo_Mara
could you please help on this.

fixed now

Hi @Shubham_Negi, how are you?

Could you share how you solved your issue?

@davi.vidal
use
securityContext:
runAsUser: 0
in initSysctl config

1 Like

I had the same error on AKS cluster.
I resolved by commenting out on values.yaml file the line privileged: true while maintaining runAsUser: 0 for the securityContext of sys-initctl initContainer.

cheers

Hi @alesspan. Welcome to our community.

Thank you and @Shubham_Negi for your time reporting this and sharing what worked for you.

We plan to update the docs on this topic soon, and your input is helpful.