SQ Enterprise 8.9 - No pull request decoration when having 2 azure devops instances configured

Hey guys,
we are running a sonarqube 8.9 enterprise in our organisation. When we configure Administration > Configuration > ALM Integrations > Azure DevOps
and add 2, or more valid configurations (Both checked and marked as green)
Then the automatic pull request decoration stops to work and we don’t get any feedback from SQ in our pipelines.
When we only configure one Azure DevOps (all of them are SaaS offerings) the decoration just worked.

What do we have to configure in SQ or in the scanner properties to decorate our PRs again? Right now SQ is just showing warnings after scans. I tried to find some solutions in the docs, but haven’t had any luck so far.

Thanks in advance!


Hey there.

If you have configured multiple ALMs – you will have to make sure that at the project-level (Project Level Project Settings > General Settings > Pull Request Decoration) the project is tied to a specific configuration and the details are entered (Project Name, Repo Name)

Hey @Colin ,
can you paste an example screenshot?

Where are the “Project Settings” ? :smiley: maybe I am blind!

Best regards,

Accessible to users who have Administer rights on a given project.

Thanks! I’ll give it a shot

Guess my admin colleague needs extend my rights :D. Thank you Collin!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.