Sonarqube upgrade database migration

We are currently using Sonarqube 7.9lts-community. We have a Postgresql 10.15 database. We would like to upgrade Sonarqube to 8.6. We are using Openshift as well. I have created an instance of Sonarqube 8.6 and pointed it at our existing database. I went to the Sonarqube url/setup and tried to run that. On that page, it says that it cannot establish a database connection after about a second. When investigating the logs of the Sonarqube pod I found some other errors. This is a very abridged stack trace:

    2021.01.07 19:25:49 INFO  web[][o.s.s.p.d.m.DatabaseMigrationImpl] Starting DB Migration and container restart
    2021.01.07 19:25:49 INFO  web[][DbMigrations] Executing DB migrations...
    2021.01.07 19:25:49 INFO  web[][DbMigrations] #3433 'Populate 'uuid' column for 'PROJECT_MEASURES''...
    2021.01.07 19:25:50 ERROR web[][DbMigrations] #3433 'Populate 'uuid' column for 'PROJECT_MEASURES'': failure | time=528ms
    2021.01.07 19:25:50 ERROR web[][DbMigrations] Executed DB migrations: failure | time=602ms
    2021.01.07 19:25:50 ERROR web[][o.s.s.p.d.m.DatabaseMigrationImpl] DB migration failed | time=1049ms
    2021.01.07 19:25:50 ERROR web[][o.s.s.p.d.m.DatabaseMigrationImpl] DB migration ended with an exception
org.sonar.server.platform.db.migration.step.MigrationStepExecutionException: Execution of migration step #3433 'Populate 'uuid' column for 'PROJECT_MEASURES'' failed

Caused by: java.sql.BatchUpdateException: Batch entry 221 update project_measures set uuid = 'AXbeT_JG-lkp_dpk2EZ8' where id = 123135 was aborted: ERROR: unexpected data beyond EOF in block 202 of relation base/16385/19991

Really not sure what any of this means and I am having trouble finding any help. Any help would be appreciated.

Thanks Much!

Hi, That looks definitely like an internal PostgreSQL error. Do you host it yourself? Can you access the PostgreSQL logs? I expect you to find the same error there. On What OS (+version) is hosted this database?

Resources online suggest that it may be linked with a kernel bug and that you need to patch your operating system. Or to increase the max_wal_size memory settings in PostgreSQL.