SonarQube server Version 7.1 (build 11001) not working in new intellij plugin

scan is not working properly after i connected and binded the proj to a sonarQube version of 7.1 from this latest sonarlint in intellij plugin Version 4.14.2

Hello, welcome to the community! And thanks for reporting this issue.

Could you please elaborate on what is not working properly? What did you try, what is the behavior you expect vs the one you observe?

Also, you might want to have a look at the SonarLint console - in the SonarLint Tool Window, open the “Log” tab, and enable “Analysis logs” and “Verbose output” from the :gear: menu.

pls see the sonarQube version


after binding to sonarQube 7.1 server i got TS error which is not needed but for java there were no issues found but i have lot of issue in server point of view.

As stated in my previous message, could you please enable the “Analysis logs” and “Verbose output” options of the “Log” tab? This could give more details about what goes wrong.

Also, I notice that the IntelliJ editor shows what looks like compile errors. This can prevent SonarLint’s Java analyzer from doing its job properly, since it relies on info extracted from the compiled bytecode. Please make sure that your Spring project is correctly imported and compiles without errors in IntelliJ.

sonarLint_logs.txt (88.4 KB)
ok got it , pls see this

Thank you for the additional details.

This is a known issue due to the old version of SonarQube that you are connecting to.

SonarQube 7.1 was released 3 years ago, even before the current LTS version - so in connected mode it will use an old version of the Java analyzer, which is not able to load the Java 11 bytecode used by IntelliJ.

I suggest that you update your SonarQube server, e.g to 7.9 LTS - especially since the next LTS will be here soon - or at the very least the version of the Java analyzer on your SonarQube server.

the thing is in eclipse its working where as in intellij is there any other possible way to use 7.1 itself since the admin is working on it

One possible workaround is to run IntelliJ with a JRE/JDK 8, if your version of IntelliJ is old enough.

I am using java 8 only thank u for the solution Jean will try it