Sonarqube Server memory configuration

I want to increase the Sonarqube server memory in the config property file, however, after restarting the server, I can see the old configuration values.
I used the following criteria to set the configuration:
The value I set is -Xmx4G -Xms1G -XX:+HeapDumpOnOutOfMemoryError -server
And below are the version I’m using.

  • Sonarqube Server Version 9.3
    Could you please help
    Thanks in advance


Welcome to the community!

I’m gonna start with a dumb question: you did uncomment those lines (remove the # at the beginning) when you updated them, right?

And if so, can you share where/how you’re seeing that the old values are still used?


Many thanks for your reply. Yes, I uncommented those settings :slight_smile:
I can see the non-changed values in the sonar server web, administration → System
Then we have Web, Compute Engine and Search Engine.
There we can find all information.
Thanks & Regards

I solved it :slight_smile:
Restarting from the web directly for some reason couldn’t get the new configuration properly.
What I did is from the bin directory just make stop then start and now I can see the new changes on the web.
Many thanks

Ah, yes. For the record, restarting from the UI doesn’t do a “full” restart.

Glad you worked through this!


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.