Impossible to increase memory using


Using Sonar 7.9 Developer edition, and we’d need to increase the allocated memory.
As mentionned in the documentation, i updated the JVM settings in conf/ :

sonar.web.javaOpts=-Xmx4G -Xms4G -XX:+HeapDumpOnOutOfMemoryError

This parameter is not taken after startup.
In the GUI it still shows the default value. How do i make the change then ?


How are you restarting the server — through the UI or on the command line (a restart of the entire service)?

Changes to the sonar.conf file won’t take effect unless the entire service is stopped and started.


thanks, this solved my issue